Agoda Errors during and after connection

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This article will help you understand the reason for the errors you may encounter during or after connecting Agoda to myallocator and how to solve them.

If you can't find the problem you're facing in this list, please contact our Support Team at support@myallocator.com. You can also reach out to your Agoda Market Manager / Support Team if you have questions about the Expedia extranet.

If you are not connected to Agoda yet, please find the connection guide here: How to connect Agoda with myallocator

Error during the connection process

Agoda Setup Error: The login details you provided are incorrect.

Problem:

When trying to setup Agoda, you receive this message:

Cause:

This is caused when your Agoda property ID is not associated with myallocator.  Agoda must associate your property ID with myallocator before it can be setup.

Solution:

You must contact Agoda to have your property ID associated with myallocator - this can only be done by Agoda and must be completed before you can setup Agoda in our system.

Errors during Full Refresh

Rates could not be updated: Some or all rates are above the maximum room rate set by the channel

Background

During a Full Refresh, the following error may appear for Agoda:

Failed: 1114 Rates could not be updated: Some or all rates are above the maximum room rate set by the channel. As an example, please check [?roomname?] with rate [?ratename?], which should be below [?rate?]. To raise the maximum rate login into your Agoda backoffice, go to Settings, Room Settings and raise the rates. (#FAULT.OTA.RATE.TOOHIGH.AGO) 

Reasons and Solutions

If any of the solutions suggested have not fixed the error, please contact us at support@myallocator.com - we'll help you resolve the issue!

Case 1. Limitation due to Minimum Rate on Agoda

Reason: There is a setting on Agoda called 'Minimum Rate.' It's set in order to prevent too low of prices being added by mistake or a third party. If you have set a price in Myallocator that is lower than the Minimum Rate set in Agoda, the channel will respond with an error during the Full Refresh.

Solution: go to your Agoda account and check the minimum rate for each room type.

You need to
A) either make sure you do not have rates in myallocator that are lower than Agoda Minimum Rate for every room and if you do- raise the room rates in myallocator (or PMS if it controls myallocator);
B) or you need to lower the Minimum Rate in Agoda for the rooms needed.

Case 2. Too low rate in myallocator

Reason: one of the rates in myallocator is too low.

Solution: check your calendar in myallocator to make sure you do not have too low of rates (for example, '1 USD' per room, it could be set by mistake).

Case 3. Single Use Rate is higher than Full/Double Rate

Reason: Single Use rate that is higher than Full  rate.
Example: price for 1 room with 2 beds costs 759, while Single Use Rate (price for 1 guest) is 799.

Solution: Change the Single Use rate so that it is lower than the Full rate and run the Full Refresh again.

Case 4. Mismatch in currency between myallocator and Agoda

Reason: in very rare cases the error is caused by a discrepancy in the currency between myallocator and Agoda.

Solution: Make sure the currency in myallocator and Agoda are the same

Please select a different rate plan for updates, as the currently selected rate plan is not enabled for updates

Background

The following error appears when performing full refresh:

"Please select a different rate plan for updates, as the currently selected rate plan is not enabled for updates."

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Solution

According to this error code the Rate plan which failed is a child rate plan which is not allowed to set rate. Most likely this rate plan is linked to another master Rate plan so the system does not allow to set the rate of the child rate plan.

In case you would like to set the rate for each rate plan separately, you need to unlink the rate plan on YCS before sending the ARI update.

Have more questions? Contact Support

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